[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Scheme-reports] Bytevectors should be called u8vectors
On Thu, Jul 19, 2012 at 2:41 PM, John Cowan <cowan@x> wrote:
> Alex Shinn scripsit:
>> What we actually voted on was: http://trac.sacrideo.us/wg/wiki/BlobAPI
>> which is similar to R6RS but encodes the endianness in the
>> names for brevity and efficiency. This was a WG2 proposal,
>> and the WG1 version of this was just the *-u8-* subset.
> I've extended BlobAPI for WG2 purposes to provide both R6RS-style names
> (byte offsets) and SRFI-4-style names (element offsets). However,
> the SRFI-4-style provides only accessors and mutators, not disjoint
> vector types.
Sure, you can change your mind about what you
think is good for WG2, but you can't retroactively
change the vote. Pending a proper WG2 vote, the
WG1 members must act under the assumption that
WG2 will have R6RS-style blobs only.
But modulo reader syntax SRFI-4 support is trivial,
and we've already provided the (srfi 4) namespace
for implementations to support.
Scheme-reports mailing list