[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Scheme-reports] Bytevectors should be called u8vectors
- To: scheme-reports@x
- Subject: Re: [Scheme-reports] Bytevectors should be called u8vectors
- From: will@x
- Date: Wed, 18 Jul 2012 12:20:01 -0400 (EDT)
- In-reply-to: <10362109.2075941342628374793.JavaMail.root@zimbra>
On Sun Jul 15 16:15:18 EDT 2012, Andy Wingo wrote:
>>> Just as another data point, I've used and implemented both APIs. I find
>>> the bytevector formulation more useful. (Incidentally, the assertion
>>> that the "bytevector" name is without history is incorrect.)
>> Fill us in on this, please?
Actually, the bytevector name and basic API date back to 1984 or 1985.
Bytevectors were provided by MacScheme (1985), and I believe they were
provided by PC Scheme (1984) as well.
Scheme-reports mailing list