[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]
Re: [Scheme-reports] Bytevectors should be called u8vectors
I think one of two things should happen:
1. If a bytevector refers to a vector of octets, then bytevector
should be renamed to u8vector, as the formal comment specifies.
2. If a bytevector is to refer to the system's native word width
(which is often called a "byte" and is not necessarily an octet), then
the standard should specify this and keep the name bytevector.
I don't think the Scheme standard should equate "byte" with "octet".
On Sat, Jun 30, 2012 at 7:23 PM, Marc Feeley <feeley@x> wrote:
> Formal Comment
> Submitter's name: Marc Feeley
> Submitter's email: feeley at iro.umontreal.ca
> Relevant draft: r7rs draft 6
> Type: defect
> Priority: minor
> Relevant section of draft: 6.9. Bytevectors
> Summary: Bytevectors should be called u8vectors
> Many implementations of Scheme have adopted SRFI-4 where bytevectors
> are called u8vectors, and where the procedures operating on
> bytevectors have u8vector in their name.
> I see no reason to introduce new names. It will require many
> implementations to implement the new names, and moreover the SRFI-4
> names will have to be kept for code which uses SRFI-4. This is
> needless bloat.
> The name u8vector is a very mnemonic way of expressing verbally the
> external representation #u8(...) which is used by R7RS for
> I also find the names bytevector-u8-ref and bytevector-u8-set!
> very clumsy and verbose compared to u8vector-ref and u8vector-set!.
> Scheme-reports mailing list
Scheme-reports mailing list